New file -> Size is much more smaller

So, I had a MKV file of an episode of a serie. The details are:
720x576 - 25FPS - 2 audiostreams - 1 VOBSUB subtitle
1,06 GIgabytes

Then I found the same episode but in HD. The details are:
1920x1080 - 29,97 FPS - 2 audiostreams - 1 UTF-8 subtitle
2,93 Gigabyte

The thing was, the subtitle of the HD file was not in my language, the first file was.
So I thought: I open them both in MKVToolNix and keep the HD-video-file but delete the subtitle and use the subtitle file of the first file.

That worked. (I know the subtitles have to be redone because the FPS from both files is not the same so the subtitle is a bit out of sync).

But when I looked at the filesize of the new file it show a size of: 860MB

Did I do something wrong? How is it possible that using the Video-file of the HD (almost 3 Gigabytes) changes into a file of 860MB?

Further info:

First file:
Used program: MakeMKV v1.15.2 win (x64-release)
Used encoderlibrary: libmakemkv v1.15.2 (1.3.10/1.5.2) win(x64-release)

Used program: mkvmerge v50.0.0 (Awakenings)
Used encoderlibrary: libebml v1.4.0 + libmatroska v1.6.2

New file:
Used program: mkvmerge v82.0 (I’m The President)
Used encoderlibrary: libebml v1.4.5 + libmatroska v1.7.1


Without having access to the files in question it’s pretty hard to say what happened. The most likely explanation is wrong usage.

Please set up the multiplexing job again the way you had it earlier & mux the file to make sure it still comes out at the (much) smaller size. Then without closing the multiplex settings select “Show command line” from the “Multiplexer” menu. Copy & paste the command line the GUI shows you in the dialog here.

@mbunkus , Thanks Moritz for replying this quick.

I did the job again (at least I think) and TaDaaaaa… the file is now 2,92 Gigabyte large, so it’s perfect.

Don’t know what I did wrong yesterday, as far as I know I did the same thing today.

When I check both files with MediaInfo I see a difference:

The old file says:
SegmentSizeIsZero: Yes
IsTruncated: Yes

This information doesn’t show with the file I created today.

So whilst I am here,…haha, I have a different question which I ran into with this.

The FPS from the old file is 25FPS and from the new file it’s 29,97FPS.

I think that causes the subtitles to be not synced anymore. Is there a way to change the FPS from the subtitle file, at the same time as I use MKVToolNix to mix those two files together?

My first thought was that you might have accidentally kept the low-res DVD video instead of the high-res video, which would fit more or less with the file size. However…

…this sounds more like the muxing process was aborted instead of finishing, either due to user interaction, due to the target disk being full or due to a bug. Hard to tell. Anyway, neither of those two properties should be shown for properly muxed files.

I suggest you look into SubtitleEdit, a program that can do all kinds of modifications with subtitles. Meaning you’ll have to get the subtitle track out of the file first, edit it with SubtitleEdit, then mux it back in again.

Thanks. And I already use Subtitle Edit (great program). But indeed I have to extract all the subs from the old files, change them, and then remux them into the new files. If it were 2 or 3 files, no problem. But I’m talking about 100 files so I wished there was an option to do this at the same time when combining the 2 files.

MKVToolNix (or rather: the CLI application it uses for muxing, mkvmerge) has an option called --sync for correcting certain types of timestamp issues. That option can adjust the timestamps for 25 to 29.976 FPS conversions. However, it only works on the container level. Certain subtitle formats include timestamp/duration information in the bitstream, though, and the option doesn’t work on those.

Nevertheless, that’s an option you can give a try. Please see the documentation for its syntax. If you want to automate such changes, take a look at the automation examples wiki page and maybe the page about batch muxing with the GUI, too.

Okay, I’ll give it a try. Unfortunately my English isn’t that good and so aren’t my technical skills, so I’ll try it. And hey, I found this forum so if I don’t understand it… :wink: