Idx file problem

I am remuxing a series of German TV shows from .avi to mkv, including subtitles. The subs are in the form of an .idx file and a .sub file. Episodes 1-11 have all worked without any issues, but episode 12 is giving me the message “The file xyz.idx’ was not recognized as a supported format (exit code: 2).” I have searched for this problem, and the answers I found referred to missing language codes. I have compared the language codes in the idx files that worked, with the one that isn’t working, and I can’t see any difference. Can anyone help me with this?
I am using MkvToolnix v82.0 and Windows 10.

EDIT: After making this post it occurred to me that the files I was remuxing had names which were much longer than I would ever use myself. I wondered if this could be causing problems. I shortened all the file names and now it is working. Is the length of filenames an known issue with MkvToolNix?


MKVToolNix doesn’t have limits wrt. to file names. That being said, Windows does have some stringent limits for the maximum length of the complete file name (which includes the drive letter, all the directory names, the separators & the file’s name & extension). One can circumvent this limit with different methods. See this FAQ entry for details.