I was deleting subtitles from Dolby Vision + HDR movie file: no DV after

Hello,
is it still like this or it looses as it is or what is wrong?
Only HDR left in file, which we have no complains lol - it brighter anyway on LG G3 then DV :frowning:

Hello,

Iā€™m actually experiencing a very similar issue. If I rip a 4k Blu-ray movie with dolby vision using latest version of MakeMKV and remux the resulting MKV file with latest version of MKVToolnix to add srt subtitles, the resulting MKV file has lost the dolby vision information. It will be displayed as HDR10 on my devices.

There is no re-encoding in the process whatsoever.

What am I doing wrong ?

[edit]: I found the answer with lots of cross reading from Google. In a nutshell it is a problem in the app I run on the device. Nothing to do with the manipulation of the MKV with MKVToolnix. Both my device and TV support DV but the app I ran (kodi) displays wrong information and does not properly decode the video track hence me noticing colour issues in the rendering. For me the solution was to get an other app.

1 Like